[Arrays]D. Liang 6.5 Printing distinct numbers.c

Description

Write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).

Input

The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100). The second line contains n integers.

Output

For each test case, outputs the distinct numbers in order in which they were read, seperated by one blank.

Sample Input

2
3
1 2 1
4
2 1 2 1

Sample Output

1 2
2 1
//   Date:2020/4/18
//   Author:xiezhg5 
#include <stdio.h>
int main(void)
{
    int m;
    scanf("%d",&m);
    int a[20][100];          //巧妙定义一个二维数组 
    int i,j,num[100];
    for(i=0;i<m;i++)
    {
        scanf("%d",&num[i]);   //把输入的数放在一个新数组中 
        for(j=0;j<num[i];j++)
        scanf("%d",&a[i][j]);
    }
    int k;
    for(i=0;i<m;i++)
    {
        printf("%d",a[i][0]);    //输出第一列的数组元素 
        for(j=1;j<num[i];j++)   
        {
            for(k=0;k<j;k++)
            {
                if(a[i][k]==a[i][j]) //元素相同则立即跳出循环 
                break;
            }
            if(k==j)              //如果不同就输出注意次序 
            printf(" %d",a[i][j]);
        }
        printf("\n");
    }
    return 0;
}
发布了245 篇原创文章 · 获赞 255 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_45645641/article/details/105602857