[Arrays]D. Liang 6.4 Analyzing scores.c

Description

Write a program that reads an unspecified number of scores and determines how many scores are above or equal to the average and how many scores are below the average. Enter a negative number to signify the end of the input. Assume the maximum number of scores is 100.

Input

The first line is a positive integer t for the number of test cases.
Each test case contains unspecified number of integers, ended by a negative integer.

Output

For each test case, outputs the count of numbers above or equal to the average and count of number below the average, seperated by one blank.

Sample Input

2
1 2 -1
2 2 2 2 -1

Sample Output

1 1
4 0
//   Date:2020/4/9
//   Author:xiezhg5
#include <stdio.h>
int main(void)
{
	double a[100]={0},sum=0,average=0;
	int m,n,i=0,flag=0,cnt=0,count=0;
	scanf("%d",&m);
	while(m--)
	{
		//一定要重新初始化 
		sum=0;
		average=0;
		cnt=0;
		count=0;
		flag=0;
		//i的最大范围是可变的多试几次随机测试就过了 
		for(i=0;i<1000;i++)
		{
			scanf("%lf",&a[i]);
			if(a[i]>=0)
			{
				sum=sum+a[i];
			    flag++;        //这样就找到了输入数字的个数 
			}
			else
			break;            //输入负数则立即退出循环 
		}
		//算平均数 
		average=sum/(flag*1.0);
		for(i=0;i<flag;i++)
		{
			if(a[i]>=average)
			cnt++;
			else
			count++;
		}
		printf("%d %d\n",cnt,count);	//记得换行标测要求 
	}
	return 0;
}
发布了208 篇原创文章 · 获赞 182 · 访问量 8640

猜你喜欢

转载自blog.csdn.net/qq_45645641/article/details/105412030