贪心 HDU2069 Coin Change

 Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score. 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

解题报告:这道题看了很久没多大思路,看了网上的题解,不过贪心的题目是真的一点没思路啊。。这题的贪心策略的是按照分数大小先排序,先把分数大的安排的尽量靠后并且在它的deadline前面,如果前面都被安排完了就必须罚分了。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<set>
#define IL inline
#define x first
#define y second
typedef long long ll;
using namespace std;
typedef pair<int,int>	PII;
const	int N=1010;
bool vis[N];
PII q[N];
bool cmp(PII a,PII b)
{
	if(a.y!=b.y)
	return a.y>b.y;
	return a.x<b.x;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(vis,0,sizeof vis);
		int n;
		cin>>n;
		for(int i=0;i<n;i++)
		cin>>q[i].x;
		for(int i=0;i<n;i++)
		cin>>q[i].y;
		sort(q,q+n,cmp);		
		ll res=0;
		for(int i=0;i<n;i++)
		{
			int j=q[i].x;
			for(;j>=1;j--)
			{
				if(!vis[j])
				{
					vis[j]=1;
					break;
				}
			}
			if(j==0)	res+=q[i].y;
		}
		cout<<res<<endl;
	}
    return 0;
}




发布了230 篇原创文章 · 获赞 9 · 访问量 3711

猜你喜欢

转载自blog.csdn.net/qq_45961321/article/details/105534923