CCF第一题--出现次数最多的数

问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s 1, s 2, …, s n (1 ≤ s i ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10


#include<stdio.h>
int main()
{
    int n,i,j,t,b,maxc=0;
    scanf("%d",&n);
    int a[n];
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    for(i=0;i<n;i++)
    {
        int cnt=0;
        for(j=0;j<n;j++)
        {
            if(a[i]==a[j])
            cnt++;
        }
        if(cnt>maxc)
        {
            maxc=cnt;
            t=i;
        }
        if(cnt==maxc&&maxc>0)
        {
            b=t;
            if(a[i]<a[b])
            t=i;
        }
    }
    printf("%d",a[t]);
    return 0;
}

发布了21 篇原创文章 · 获赞 3 · 访问量 5364

猜你喜欢

转载自blog.csdn.net/cherryyiyi/article/details/65448392