记忆性搜索 滑雪(第二次写)

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。 

Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

解题报告:这道题纯粹是我忘记dfs咋写了。。要先把这个点的距离初始化成1,他只会被相邻的比它小的点所更新

#include<iostream>
#include<cstring>
using namespace std;
const	int N=110;
int n,m;
int a[N][N];
int dis[N][N];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
void dfs(int x,int y)
{
	dis[x][y]=1;	
	for(int i=0;i<4;i++)
	{
		int tx=x+dx[i];
		int ty=y+dy[i];
		if(tx<0||ty<0||tx>=n||ty>=m||a[x][y]<=a[tx][ty])	continue;
		if(!dis[tx][ty])	
		dfs(tx,ty);
		dis[x][y]=max(dis[x][y],dis[tx][ty]+1);
		
		
		}
}
int main()
{
	cin>>n>>m;
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	cin>>a[i][j];
	int ans=0;
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	{
		if(!dis[i][j])
		{
			dfs(i,j);
			ans=max(dis[i][j],ans);
		}
	}
	cout<<ans<<endl;
}
发布了215 篇原创文章 · 获赞 9 · 访问量 3543

猜你喜欢

转载自blog.csdn.net/qq_45961321/article/details/105186761