Overflow(UVA - 465)

最近新学了一个函数的用法,头文件是 stdlib.h atof() 的函数,它可以把字符串的数字转化为double类型。

题目:

Write a program that reads an expression consisting of two non-negative integer and an operator.Determine if either integer or the result of the expression is too large to be represented as a “normal”signed integer (typeintegerif you are working Pascal, typeintif you are working in C).
Input
An unspecified number of lines. Each line will contain an integer, one of the two operators ‘+’ or ‘*’,and another integer.
Output
For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ‘first number too big’, ‘second number too big’, ‘result too big’.Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big

解题思路:就是先判断两个数是否超出范围,然后再判断加和乘结果是否超出范围。
1、atof()函数写法:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
long long max=2147483647;
int main()
{
	char s[5000],s1[5000],t;
	double u,v;
	while(scanf("%s %c %s",s,&t,s1)!=EOF)
	{
		printf("%s %c %s\n",s,t,s1);
		u=atof(s);
		v=atof(s1);
		if(u>max)
			printf("first number too big\n");
		if(v>max)
			printf("second number too big\n");
		if(t=='+'&&u+v>max)
			printf("result too big\n");
		else if(t=='*'&&u*v>max)
			printf("result too big\n");		
	}
	return 0;
}

2、不用atof()函数的代码:

#include<stdio.h>
#include<string.h>
long long max=2147483647;
int main()
{
	char s[5000],s1[5000],t;
	int n,m,i,j,k;
	long long u,v;
	while(scanf("%s %c %s",s,&t,s1)!=EOF)
	{
		printf("%s %c %s\n",s,t,s1);
		n=strlen(s);
		m=strlen(s1);
		u=v=0;
		for(i=0;i<n;i++)
		{
			u=u*10+s[i]-'0';
			if(u>max)
			{
				printf("first number too big\n");
				break;
			}
		} 
		for(i=0;i<m;i++)
		{
			v=v*10+s1[i]-'0';
			if(v>max)
			{
				printf("second number too big\n");
				break;
			}
		}
		if(t=='+'&&u+v>max)
			printf("result too big\n");
		else if(t=='*'&&u*v>max)
			printf("result too big\n");		
	}
	return 0;
}
发布了67 篇原创文章 · 获赞 39 · 访问量 2728

猜你喜欢

转载自blog.csdn.net/qq_44859533/article/details/100630504