Hduoj 2004题解

题目

Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;

Input
输入数据有多组,每组占一行,由一个整数组成。

Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。

样例

Sample Input
56
67
100
123

Sample Output
E
D
A
Score is error!

题解如下:

#include<stdio.h>
int main(){
    int t;
    while(scanf("%d",&t)!=EOF){
        if(t<0||t>100){
           printf("Score is error!\n");
        }
        else{
            if(t>=0&&t<60){
                printf("E\n");
            }
            if(t>=60&&t<70){
                printf("D\n");
            }
            if(t>=70&&t<80){
                printf("C\n");
            }
            if(t>=80&&t<90){
                printf("B\n");
            }
            if(t>=90&&t<=100){
                printf("A\n");
            }
        }
    }
    return 0;
}

发布了12 篇原创文章 · 获赞 0 · 访问量 719

猜你喜欢

转载自blog.csdn.net/weixin_43252204/article/details/103637272
今日推荐