hdu6024 Building Shops(DP)

题目链接
Problem Description
HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.

Output
For each test case, print a single line containing an integer, denoting the minimal cost.

Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1

Sample Output
5
11

Source
2017中国大学生程序设计竞赛 - 女生专场

思路:dp【i】【0】表示i点建的最小花费,dp【i】【1】表示i点不建的最小花费。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+1;
const int inf=0x3f3f3f3f;
ll dp[maxn][2];
pair<ll,ll>p[maxn];
bool cmp(const pair<int,int>&a,const pair<int,int>&b)
{
    return a.first<b.first;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,inf,sizeof(dp));
        for(int i=1;i<=n;++i) scanf("%lld %lld",&p[i].first,&p[i].second);
        sort(p+1,p+1+n,cmp);
        dp[1][1]=p[1].second;
        for(int i=2;i<=n;++i)
        {
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+p[i].second;
            ll sum=0;
            for(int j=i-1;j>=1;--j)
            sum+=(i-j)*(p[j+1].first-p[j].first),
            dp[i][0]=min(dp[i][0],dp[j][1]+sum);
        }
        printf("%lld\n",min(dp[n][0],dp[n][1]));
    }
}
发布了328 篇原创文章 · 获赞 1 · 访问量 9107

猜你喜欢

转载自blog.csdn.net/qq_42479630/article/details/105208854
今日推荐