问题 B: c#计算长方形的面积(继承问题)

题目描述

根据给出的代码,补全缺失的代码,输入两个数字为长方形的长和宽,从而得出长方形的面积。


using System;
namespace InheritanceApplication
{
   class Shape 
   {
      public void setWidth(int w)
      {
         width = w;
      }
      public void setHeight(int h)
      {
         height = h;
      }
      protected int width;
      protected int height;
   }
/****************/
编写此处代码,并只提交此处代码
/****************/
   
   class RectangleTester
   {
      static void Main(string[] args)
      {
         Rectangle Rect = new Rectangle();
        int width = int.Parse(Console.ReadLine());
          int height =int.Parse(Console.ReadLine());
         Rect.setWidth(width);
         Rect.setHeight(height);
         Console.WriteLine("总面积: {0}",  Rect.getArea());
         Console.ReadKey();
      }
   }
}

输入

3 5

输出

15

样例输入

5
7

样例输出

35

using System;
namespace InheritanceApplication
{
    class Shape
    {
        public void setWidth(int w)
        {
            width = w;
        }
        public void setHeight(int h)
        {
            height = h;
        }
        protected int width;
        protected int height;
    }

    class Rectangle:Shape
    {
        public int getArea()
        {
            return width * height;
        }
    }

    class RectangleTester
    {
        static void Main(string[] args)
        {
            Rectangle Rect = new Rectangle();
            int width = int.Parse(Console.ReadLine());
            int height = int.Parse(Console.ReadLine());
            Rect.setWidth(width);
            Rect.setHeight(height);
            Console.WriteLine("总面积: {0}", Rect.getArea());
            Console.ReadKey();
        }
    }
}

  

提交部分

    class Rectangle:Shape
    {
        public int getArea()
        {
            return width * height;
        }
    }

  

猜你喜欢

转载自www.cnblogs.com/mjn1/p/12618940.html
今日推荐