【C】二分查找

课程:数据结构陈越何钦铭


本题要求实现二分查找算法。

函数接口定义:

Position BinarySearch( List L, ElementType X );

其中List结构定义如下:

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

L是用户传入的一个线性表,其中ElementType元素可以通过>、==、<进行比较,并且题目保证传入的数据是递增有序的。函数BinarySearch要查找XData中的位置,即数组下标(注意:元素从下标1开始存储)。找到则返回下标,否则返回一个特殊的失败标记NotFound

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 10
#define NotFound 0
typedef int ElementType;

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List ReadInput(); /* 裁判实现,细节不表。元素从下标1开始存储 */
Position BinarySearch( List L, ElementType X );

int main()
{
    List L;
    ElementType X;
    Position P;

    L = ReadInput();
    scanf("%d", &X);
    P = BinarySearch( L, X );
    printf("%d\n", P);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

5
12 31 55 89 101
31

输出样例1:

2

输入样例2:

3
26 78 233
31

输出样例2: 

0

代码:

自己实现了ReadInput()函数用于测试,细节在代码最后部分,不太完善但可以使用。

要注意,在对结构体内的成员初始化前,要对结构体指针分配内存,不然会出现内存错误。

参考资料:c语言结构体指针初始化

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 10
#define NotFound 0
typedef int ElementType;

typedef int Position;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};
typedef struct LNode *List;

List ReadInput(); /* 元素从下标1开始存储 */
Position BinarySearch( List L, ElementType X );

int main()
{
    List L;
    ElementType X;
    Position P;

    L = ReadInput();
    
    scanf("%d", &X);
    P = BinarySearch( L, X );
    printf("%d\n", P);

    return 0;
}

/* 你的代码将被嵌在这里 */
Position BinarySearch( List L, ElementType X ){
    Position minP = 1, maxP = L->Last, midP;
    Position retP = NotFound;
    while(minP <= maxP ){
        midP = (minP + maxP)/2;
        if(L->Data[midP] == X){
            retP = midP;
            break;
        }
        else if(L->Data[midP] > X){
            maxP = midP - 1;
            continue;
        }
        else{
            minP = midP + 1;
            continue;
        }
    }
    return retP;
}

/* 输入数据存入结构对象中,返回指针 */
List ReadInput(){
    List pList = (List)malloc(sizeof(struct LNode));
    pList->Data[0] = 0;
    int n;
    scanf("%d",&n);
    for(int i=1; i<=n; i++){
        scanf("%d",&(pList->Data[i]));
    }
    pList->Last = n;
    return pList;
}
发布了37 篇原创文章 · 获赞 47 · 访问量 10万+

猜你喜欢

转载自blog.csdn.net/u013378642/article/details/105036929