ALDS1_3_B:Queue

输入:数量n 单个任务最长执行时间

输出:n行 每行任务名称+任务所需时间

如果任务需要时间超出了最长执行时间,则将所需时间减去最长执行时间后再压入队列尾部。直到栈为空结束。


Sample Input 1

5 100
p1 150
p2 80
p3 200
p4 350
p5 20

Sample Output 1

p2 180
p5 400
p1 450
p3 550
p4 800


#include <cstdio>
#include <queue>
#include <string>
#include <vector>
#include <algorithm>
#include <iostream>
using namespace std;
int main(){
	int n , p ,t ;
	string name;
	int timeflow=0;
	cin>>n>>p;
	queue<pair<string,int> > A;
	for(int i = 1 ; i<=n;i++){
		cin>>name>>t;
		A.push(make_pair(name, t));
	}
	while(!A.empty()){
		if(A.front().second<=p){
			timeflow+=A.front().second;
			cout<<A.front().first<<" "<<timeflow<<endl;
			A.pop();
		}
		else{
			timeflow+=p;
			A.front().second-=p;
			A.push(A.front());
			A.pop();
		}
	}
	return 0;
}


错点:

1.定义时 要写成queue<pair<string,int> > 最后的尖括号之间要有空格

猜你喜欢

转载自blog.csdn.net/qq_33982232/article/details/80298889