UCF Local Programming Contest 2016 2020.3.28

 A. Majestic 10

The movie "Magnificent 7" has become a western classic. Well, this year we have 10 coaches training the UCF programming teams and once you meet them, you’ll realize why they are called the "Majestic 10"! The number 10 is actually special in many different ways. For example, in basketball, they keep track of various statistics (points scored, rebounds, etc.) and if a player has 10+ (10 or more) in a particular stat, they call it a double.

The Problem:

Given three stats for a basketball player, you are to determine how many doubles the player has, i.e., how many of the stats are greater than or equal to 10. 

The Input: 

The first input line contains a positive integer, n, indicating the number of players. Each of the following n input lines contains three integers (separated by a space and each between 0 and 100, inclusive), providing the three stats for a player. 

The Output: 

Print each input line as it appears in the input. Then, on the following output line, print a message indicating how many stats are greater than or equal to 10: 

    print zilch if none of the three stats is greater than or equal to 10, 

    print double if one of the three stats is greater than or equal to 10, 

    print double-double if two of the three stats are greater than or equal to 10,

    print triple-double if all three stats are greater than or equal to 10. 

Leave a blank line after the output for each player. 

样例输入

4 
5 0 8 
30 10 50 
20 5 20 
5 100 6

样例输出

5 0 8 
zilch

30 10 50 
triple-double 

20 5 20 
double-double 

5 100 6 
double
题解:这题思路比较简单,就是直接判断这3个数字有几个超过10的数字,没有超过输出zilch,一个超过输出double,然后double-double triple-double,用if一个一个判断就好
直接看代码:
#include<iostream>
using namespace std;
int main(){
	int n,a[1001],sum;
	cin>>n;
	while(n--){
		sum=0;
		for(int i=0;i<3;i++){
			cin>>a[i];
			if(a[i]>=10){
				sum++;
			}
		}
		for(int i=0;i<2;i++){
			cout<<a[i]<<" ";
		}
		cout<<a[2]<<endl;
		if(sum==0){
			cout<<"zilch"<<endl;
		}
		if(sum==1){
			cout<<"double"<<endl;
		}
		if(sum==2){
			cout<<"double-double"<<endl;
		}
		if(sum==3){
			cout<<"triple-double"<<endl;
		}
		if(n!=0){
			cout<<endl;
		}
	}
} 
 
          
 

猜你喜欢

转载自www.cnblogs.com/liyongqi/p/12591775.html