杭电oj1073:Online Judge

Online Judge

题目链接

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user’s result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return “Accepted”, else if the only differences between the two files are spaces(’ ‘), tabs(’\t’), or enters(’\n’), the Judge System should return “Presentation Error”, else the system will return “Wrong Answer”.

Given the data of correct output file and the data of user’s result file, your task is to determine which result the Judge System will return.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user’s result file. Both of them are starts with a single line contains a string “START” and end with a single line contains a string “END”, these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END

Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

这个题竟然没有一遍过,啊啊啊啊,太弱了。
第一天做的时候也不知道哪儿错了,快11点了,就睡觉了。
第二天再做的时候,重新码了一遍,一次AC。
其实思路很简单:把the data of correct output file and the data of the user’s result file分别读到两个string中,如果相等,则AC;否则将两个string中的特殊字符全部去掉,如果相等,则为PE;否则为WA。

#include<iostream>
using namespace std;

int main()
{
	//freopen("in.txt", "r", stdin);
	int num;
	cin>>num;
	while(num--)
	{
		string start;
		string correct="", error="";//最好赋值为空
		cin>>start;
		while(getline(cin, start))
		{
			if(start == "END")
				break;
			if(start.length() == 0)
				correct += "\t";
			else
				correct += start;
		}
		cin>>start;
		while(getline(cin, start))
		{
			if(start == "END")
				break;
			if(start.length() == 0)
				error += "\t";
			else
				error += start;
		}
		
		if(correct == error){
			cout<<"Accepted"<<endl;
			continue;
		}
		string c_copy="", e_copy = "";
		int len = correct.length();
		for(int i=0;i<len;i++)
		{
			if(correct[i] == ' ' || correct[i] == '\t' || correct[i] == '\n')
				continue;
			c_copy += correct[i];
		}
		len = error.length();
		for(int i=0;i<len;i++)
		{
			if(error[i] == ' ' || error[i] == '\t' || error[i] == '\n')
				continue;
			e_copy += error[i];
		}
		if(e_copy == c_copy)
			cout<<"Presentation Error"<<endl;
		else
			cout<<"Wrong Answer"<<endl;
	}
	return 0;
}
发布了52 篇原创文章 · 获赞 36 · 访问量 4503

猜你喜欢

转载自blog.csdn.net/qq_38861587/article/details/104484703
今日推荐