Codeforce 735D 哥德巴赫猜想

Taxes
TimeLimit:2000MS MemoryLimit:256MB
64-bit integer IO format:%I64d

Problem Description
Mr. Funt now lives in a country with a very specific tax laws. The total income of mr. Funt during this year is equal to n (n ≥ 2) burles and the amount of tax he has to pay is calculated as the maximum divisor of n (not equal to n, of course). For example, if n = 6 then Funt has to pay 3 burles, while for n = 25 he needs to pay 5 and if n = 2 he pays only 1 burle.

As mr. Funt is a very opportunistic person he wants to cheat a bit. In particular, he wants to split the initial n in several parts n1 + n2 + … + nk = n (here k is arbitrary, even k = 1 is allowed) and pay the taxes for each part separately. He can’t make some part equal to 1 because it will reveal him. So, the condition ni ≥ 2 should hold for all i from 1 to k.

Ostap Bender wonders, how many money Funt has to pay (i.e. minimal) if he chooses and optimal way to split n in parts.

Input
The first line of the input contains a single integer n (2 ≤ n ≤ 2·109) — the total year income of mr. Funt.

Output
Print one integer — minimum possible number of burles that mr. Funt has to pay as a tax.

SampleInput 1
4
SampleOutput 1
2
SampleInput 2
27
SampleOutput 2
3

题意:给你一个数n,可将n分成k个部分,税收是每个部分最大的能整除的数,问最少税收是多少
思路:显然可以看出最好分解成质数这样使得每部分花费最小是1,所以这样的解是最少且最优秀的。现在的问题就是怎样分解出质数,然后就涨姿势了 有个东西叫 哥德巴赫猜想。
哥德巴赫猜想:任一大于2的偶数都可写成两个质数之和。强哥德巴赫猜想 每个不小于2 的偶数都是两个奇素数之和。
弱哥德巴赫猜想 每个不小于2 的奇数都是三个奇素数之和。

这样思路就很清晰辽 , 1.先判断n本身是否是质数 如果是 直接输出 1,2.如果n是偶数 根据 强猜想 可以得到他一定是两个质数之和而且是奇质数 所以输出 2 . 3.如果是奇数 根据弱哥德巴赫猜想 他可以由三个质数之和得到 所以输出3 或者 你可以将n减去质数2 判断其减去后是否为质数 如果是 输出 2 (2和n-2都是质数) 不是的话 则说明其是个偶数 那么就输出 3 (2为质数,n不是质数但是是偶数)

下面献上我的low逼代码

#include <iostream>

using namespace std;

bool isprime(int n)
{
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
            return 0;
    }
    return 1;
}

int main()
{
    int n;

    cin >> n;

    if(n==1||isprime(n))
        cout << "1" << endl;
    else if(n%2==0)
        cout << "2" << endl;
    else
    {
        if(isprime(n-2))
            cout << "2" << endl;
        else
            cout << "3" << endl;
    }

    return 0;
}
发布了54 篇原创文章 · 获赞 0 · 访问量 1221

猜你喜欢

转载自blog.csdn.net/weixin_44144278/article/details/99779645