PTA 6-3 逆序数据建立链表 (20分)

PTA逆序数据建立链表

本题要求实现一个函数,按输入数据的逆序建立一个链表。
**函数接口定义:**struct ListNode *createlist();

  • 要求

函数createlist利用scanf从输入中获取一系列正整数,当读到−1时表示输入结束。按输入数据的逆序建立一个链表,并返回链表头指针。链表节点结构定义如下:

struct ListNode {
    int data;
    struct ListNode *next;
};
  • 裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
   int data;
   struct ListNode *next;
};

struct ListNode *createlist();

int main()
{
   struct ListNode *p, *head = NULL;

   head = createlist();
   for ( p = head; p != NULL; p = p->next )
       printf("%d ", p->data);
   printf("\n");

   return 0;
}

/* 你的代码将被嵌在这里 */
  • 输入样例:
    1 2 3 4 5 6 7 -1

  • 输出样例:
    7 6 5 4 3 2 1

  • 我的函数

struct ListNode *createlist()
{
   struct ListNode *   head,*q;
   head = (struct ListNode *)malloc(sizeof(struct ListNode));
   head->next = NULL;
   while(1)
   {
       q = (struct ListNode *)malloc(sizeof(struct ListNode));
       scanf("%d",&q->data);
       if(q->data == -1)
       break;
       q->next = head ->next;
       head->next = q;
       
   }
   return head->next;//这个返回值不知道为什么返回head一直会出错..可能我的代码有问题
}
/*返回head时
1 2 3 4 -1
11229056 4 3 2 1
会出错...
*/

2019/12/28 14/54

发布了21 篇原创文章 · 获赞 5 · 访问量 742

猜你喜欢

转载自blog.csdn.net/weixin_45862170/article/details/103744565