PAT A1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2… NK aNK
where K is the number of nonzero terms in the polynomial, N​i and aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

Meaning of the questions:

The sum of two polynomials output format (non-zero indices descending output):
nonzero entry number of nonzero coefficients of non-zero indices ...

Ideas:

(1) takes three floating-point array of a, b, c, storing the input two polynomials with the polynomial sum, the subscript index, the corresponding coefficient value;
(2) A, B are added one by one c is obtained, the number of the output c of non-zero entries, the descending output index and a coefficient c.

Code:

#include <cstdio>
#include <iostream>
#include <iomanip>
using namespace std;
const int maxn=1010;
int main(){
	int k1,k2,n1,n2,count=0;
	double a1,a2,a[maxn]={},b[maxn]={},c[maxn]={};
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>n1>>a1;
		a[n1]=a1;
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>n2>>a2;
		b[n2]=a2;
	}
	for(int i=0;i<maxn;i++){
		c[i]=a[i]+b[i];
		if(c[i]!=0){
			count++;
		}
	}
	cout<<count;
	cout<<setiosflags(ios::fixed)<<setprecision(1);//保留1位小数点输出
	for(int i=maxn-1;i>=0;i--){
		if(c[i]!=0)
		cout<<' '<<i<<' '<<c[i];
	}
	return 0;
}

vocabulary:

polynomial polynomial
coefficient coefficient
exponent index

Published 26 original articles · won praise 0 · Views 497

Guess you like

Origin blog.csdn.net/PanYiAn9/article/details/101550163