PAT Class --1002 A + B for Polynomials (25 minutes)

Similar thinking count (barrel) sort, define an array, the array subscripts represent index value representing an array factor, a space for time, anyway, only 1000 MAX.

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

//1002
#include <iostream>
#include <math.h>

using namespace std;
const int MAX=1001;

int main(){
	
	int k1,k2;
	float a1[MAX]={0};
	int a;
	float b;
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>a>>b;
		a1[a]+=b;
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>a>>b;
		a1[a]+=b;
	}

	int sum=0;
	for(int i=MAX;i>=0;i--){
		if(a1[i]!=0.0){
			sum++;
		}
	}
	cout<<sum;
	for(int i=MAX;i>=0;i--){
		if(a1[i]!=0.0){
			cout<<" "<<i;
			printf(" %.1f",a1[i]);
		}
	}
        return 0;
}

But I wrote two arrays together form, I had no idea what the problem is, so can only take 17 minutes to write ......? ? ?

First down

//1002
#include <iostream>
#include <math.h>

using namespace std;
const int MAX=1001;

int main(){
	
	int k1,k2;
	float a1[MAX]={0};
	float a2[MAX]={0};
	float a3[MAX]={0};
	int a;
	float b;
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>a>>b;
		a1[a]+=b;
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>a>>b;
		a2[a]+=b;
	}
	if(k1==0&&k2==0){
		cout<<0;
	}else{
		int sum=0;
		for(int i=MAX;i>=0;i--){
			if(a1[i]!=0.0||a2[i]!=0.0){
				a3[i]=a1[i]+a2[i];
				sum++;
			}
		}
		cout<<sum;
		for(int i=MAX;i>=0;i--){
			if(a3[i]!=0.0){
				cout<<" "<<i;
				printf(" %0.1f",a3[i]);
			}
		}
	}

	
	
	return 0;
}

 

Published 235 original articles · won praise 217 · Views 100,000 +

Guess you like

Origin blog.csdn.net/qq_41895747/article/details/104071136