1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2


#include <the iostream> 
#include <cstdio> 
#include < String .h> the using namespace STD;
 Double A [ 1001 ] = { 0.0 };
 char str [ 1000 ] = "" , str1 [ 100 ]; // the str [ 100] expand 1000, run-time error can remove int main () {
     int n-; 
    CIN >> n-;
     int I;
     Double J;
     the while (N-- ) { 
        CIN >> >> I J; 
        A [I]

 
+= j;
    }
    cin >> n;
    while (n--) {
        cin >> i >> j;
        a[i] += j;
    }
    int cnt = 0;
    for (i = 1000; i >= 0; i--) {
        if (a[i] != 0) {
            sprintf(str1, " %d %0.1lf", i, a[i]);
            strcat(str, str1);
            cnt++;
        }
    }
    cout << cnt << str;
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/TBhacker/p/11271334.html