A1002. A+B for Polynomials

Title Description

  This time, you are supposed to find A+B where A and B are two polynomials

Input Format

  Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK , where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,...,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤Nk<...<N2<N≤1000

Output Format

  For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line.

Please be accurate to 1 decimal place.

SAMPLE INPUT

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

The meaning of problems

  • Given two rows, each row represents a polynomial, the first number indicates the number of entries polynomial coefficients of non-zero entries, each represented by two digits after one, two numbers represent the coefficients and the power of the. Determine and two polynomials, and outputting the same results to the same format as previously

Sample interpretation

  • 2 is a first means two polynomial coefficients have non-zero entries, 1 item 2.4 represents a coefficient represented by the coefficient 3.2 to 2.4,0 (i.e. constant term) zero term is 3.2, that is F1 (x) = 2.4 x + 3.2
  • Likewise the second row can be written as a polynomial representation F2 (X) = 1.5x 2 + 0.5x
  • Then Fl (X) + F2 of (X) = 1.5x 2 + 2.9x + 3.2 
#include <bits/stdc++.h>
const int max_n = 1111;
double p[max_n] = {};
int main(int argc, char *argv[]) {
    int k, n, count = 0;
    double a;
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        scanf("%d %1f", &n, &a);
        p[n] += a;
    }
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        scanf("%d %1f", &n, &a);
        p[n] += a;
    }
    for(int i = 0; i < max_n; i++){
        if(p[i] != 0){
            count++;
        }
    }
    printf("%d", count);
    for(int i = max_n - 1; i >= 0; i--){
        if(p[i] != 0){
            printf( "%d %.1f", i, p[i]);
        }
    }
    return 0;    
}

Guess you like

Origin www.cnblogs.com/YC-L/p/12187244.html