1142 Maximal Click (25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
#include<iostream>
#include<vector>
#include<unordered_set>
using namespace std;

int main(){
    int nv, ne;
    cin >> nv >> ne;
    int graph[201][201] = {0};
    
    for(int i = 0; i < ne; i++){
        int temp_a, temp_b;
        scanf("%d %d", &temp_a, &temp_b);

        graph[temp_a][temp_b] = graph[temp_b][temp_a] = 1;

    }

    int m;
    cin >> m;
    for(int i = 0; i < m; i++){
        int k;
        scanf("%d", &k);
        vector<int> vec(k);
        int flag[201] = {0};
        bool is_clique = true;
        for(int j = 0; j < k; j++){
            int temp;
            scanf("%d", &vec[j]);
            flag[vec[j]] = 1;

        }
        for(int j = 0; j < k; j++){
            for(int z = j + 1; z < k; z++){

                if(graph[vec[j]][vec[z]] == 0){
                    is_clique = false;
                    printf("Not a Clique\n");
                    break;

                }
                
            }
            if(!is_clique){
                break;
            }

        }
        if(is_clique){
            bool max_clique = true;
            bool kkk = false;
            for(int j = 1; j <= nv; j++){
                if(flag[j] == 0){
                    int count = 0;
                    for(int w = 0; w < k; w++){
                        if(graph[j][vec[w]] == 0){
                            
                            max_clique = false;
    
                        }else{
                            count++;                          
                        }
                        if(count == k){

                            kkk = true;
                        }
                        
                    }
                    
                }

            }
            if(!kkk){
                
                printf("Yes\n");

            }else
            {
                printf("Not Maximal\n");
            }
            

        }
        


    }





    return 0;
}

 

Published 32 original articles · won praise 0 · Views 360

Guess you like

Origin blog.csdn.net/zbchenchanghao/article/details/104080516