PTA Mice and Rice (25分)

It is the human mind that releases infinite light, and it is also the human mind that creates boundless darkness. Light and darkness are intertwined and fight together. This is the world for which we are nostalgic and helpless.

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include<climits>//INT_MAX
//#include<bits/stdc++.h>
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
typedef long long ll;
using namespace std;
int const mod=1e9+7;
const int maxn=1e4+10;
struct node{
    int w;
    int jg;
}P[maxn];
int np,ng;
int main()
{
    scanf("%d%d",&np,&ng);
    for(int i=0;i<np;i++)
        scanf("%d",&P[i].w);
    queue<int>q;
    for(int i=0;i<np;i++)
    {
        int x;
        scanf("%d",&x);
        q.push(x);
    }
    int tmp=np,d;
    while(q.size()!=1)
    {
        if(tmp%ng==0)
            d=tmp/ng;
        else
            d=tmp/ng+1;
        for(int i=0;i<d;i++)
        {
            int k=q.front();
            for(int j=0;j<ng;j++)
            {
                if(i*ng+j>=tmp)
                    break;
                int v=q.front();
                q.pop();
                if(P[v].w>P[k].w)
                    k=v;
                P[v].jg=d+1;
            }
            q.push(k);
        }
        tmp=d;
    }
    P[q.front()].jg=1;
    for(int i=0;i<np;i++)
    {
        printf("%d",P[i].jg);
        if(i!=np-1)
            printf(" ");
    }
    return 0;
}

 

Guess you like

Origin blog.csdn.net/weixin_44170305/article/details/108544753