1016 Phone Bills (25 分)

Disclaimer: This article is a blogger original article, follow the CC 4.0 BY-SA copyright agreement, reproduced, please attach the original source link and this statement.
This link: https://blog.csdn.net/weixin_42582136/article/details/102652827

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

It is clear meaning of the questions, the output of each person's phone bill in the format:

Name, month
starting time of a single active call, end time, talk time, a single call costs
Total costs

The question is not difficult to match with the campus phone records of a vehicle that question is the same, are the closest match, you can go and see another article I wrote, but I started only had two points, or like a long time to see where there are problems, but finally saw someone else's answer that no reasonable person do not call records output. Then you can change the past, lack of attention or consideration, subject only to ensure that there is at least one valid record, but there is no guarantee that everyone has an effective call records.

#include<bits/stdc++.h>
using namespace std;
struct bill{
	string name, time, status;
};
int main()
{
	vector<double>rate_stru(24),vector<double>rate_sum(24);
	double one_day = 0;
	for (int i = 0; i < 24; i++){
		cin >> rate_stru[i];
		rate_stru[i] /= 100.0;
		one_day += rate_stru[i];
		rate_sum[i] = (i > 0 ? rate_sum[i - 1] + rate_stru[i - 1] * 60 : 0);
	}
	int n;
	cin >> n;
	bill b;
	vector<bill>Bills;
	map<string, vector<bill>>person;
	for (int i = 0; i < n; i++){
		cin >> b.name >> b.time >> b.status;
		person[b.name].push_back(b);
	}
	for (auto& it : person)
	{
		double total = 0;
		struct output{
			string on_line, off_line;
			int tatal;
			double price;
		};
		vector<output>ret;
		sort(it.second.begin(), it.second.end(), [](bill& a, bill& b) {return a.time < b.time; });
		for (int i = 0; i < it.second.size() - 1; i++)
			if (it.second[i].status == "on-line" && it.second[i + 1].status == "off-line")
			{
				string start = it.second[i].time, end = it.second[i + 1].time;
				int s_dd = stoi(start.substr(3, 2)), s_hh = stoi(start.substr(6, 2)), s_mm = stoi(start.substr(9, 2));
				int e_dd = stoi(end.substr(3, 2)), e_hh = stoi(end.substr(6, 2)), e_mm = stoi(end.substr(9, 2));
				int dif = (e_dd - s_dd) * 1440 + e_hh * 60 + e_mm - s_hh * 60 - s_mm;
				double left = (s_hh > 0 ? rate_sum[s_hh] : 0) + s_mm * rate_stru[s_hh];
				double right = (e_dd - s_dd) * one_day * 60 + (e_hh > 0 ? rate_sum[e_hh] : 0) + e_mm * rate_stru[e_hh];
				double tmp = (right - left);
				ret.push_back({ start.substr(3).c_str(), end.substr(3).c_str() ,dif ,tmp });
				total += tmp;
			}
		if (ret.size()){
			cout << it.first << " " << it.second.front().time.substr(0, 2) << endl;
			for (auto& it:ret)
				printf("%s %s %d $%.2f\n", it.on_line.c_str(), it.off_line.c_str(), it.tatal, it.price);
			printf("Total amount: $%.2f\n", total);
		}
	}
	return 0;
}

Guess you like

Origin blog.csdn.net/weixin_42582136/article/details/102652827