Router RIP dynamic routing configuration

Experimental environment configuration

2 PCs; 1 Switch_3560; 2 Router-PTs; Straight Cable; Crossover Cable; DCE Serial Cable

Experimental procedure

  1. Create a new topology

insert image description here
The host and the switch are connected by a straight cable, and the host and the router are connected by a crossover cable. The routers are connected through serial ports, and the DCE end is connected to R1, which needs to be configured with a clock frequency of 64000.

insert image description here

  1. Configure switch S3560: VLAN10 is used to connect to the host on the campus network, and VLAN20 is used to connect to R1.

(1) First divide VLAN10 and VLAN20 based on interfaces, VLAN10 port members (f0/10), VLAN20 port members (f0/20),

switch(config)#int vlan 10
switch(config-if)#exit
switch(config)#int vlan 20
switch(config-if)#exit
switch(config)#int f0/10
switch(config-if)#switchport access vlan 10
switch(config)#int f0/20
switch(config-if)#switchport access vlan 20

(2) Verify, display VLAN information

insert image description here

  1. Configure the IP address of VLAN10: 192.168.1.1 255.255.255.0, configure the IP address of VLAN20: 192.168.3.1 255.255.255.0
switch(config)#int vlan 10
switch(config-if)#ip address 192.168.1.1 255.255.255.0
switch(config-if)#no shutdown

vlan 20 operation is the same as above

  1. (1) Configure router R1:
    configure the ip address of fa 0/0 192.168.3.2 255.255.255.0, configure the ip address of serial 2/0 192.168.4.1 255.255.255.0 and the clock frequency 64000.
switch(config-if)#clock rate 64000

(2) Configure RIP routing:

switch(config)#router rip
switch(config)#network 192.168.3.0
switch(config)#network 192.168.4.0
switch(config)#version 2
  1. (1) Configure router R2:
    configure the ip address of fa 0/0 192.168.2.1 255.255.255.0, and configure the ip address of serial 2/0 192.168.4.2 255.255.255.0.

(2) Configure RIP routing:

switch(config)#router rip
switch(config)#network 192.168.2.0
switch(config)#network 192.168.4.0
switch(config)#version 2

insert image description here

  1. Configure switch S3560 RIP routing (enter global configuration mode)
switch(config)#router rip
switch(config)#network 192.168.1.0
switch(config)#network 192.168.3.0
switch(config)#version 2

In the case of IP routing not enabled , use the following solutions:

switch(config)#router rip
switch(config-router)#exit
switch(config)#router rip
switch(config-router)#

verify

To test whether PC1 and PC2 are connected,
wait for 30s to verify the result

insert image description here

Guess you like

Origin blog.csdn.net/qq_50767141/article/details/121643033