PAT-1019 General Palindromic Number


A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as ∑i=0k(aibi). Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “ak ak−1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

Ideas

Base conversion, judging the number of palindrome, pay attention to the special case of n=0.

Code


#include <iostream>
#include <vector>
using namespace std;

vector<int>data;
bool Judge(vector<int>data){
    
    
    for (int i=0; i<data.size()/2; i++){
    
    
        if (data[i] != data[data.size()-i-1])   return false;
    }
    return true;
}
int main(){
    
    
    int n,k;
    cin>>n>>k;
    if (n==0) data.push_back(0);  // 注意n=0的特殊情况
    while (n != 0){
    
    
        data.push_back(n%k);
        n = n/k;
    }
    if (Judge(data))    cout << "Yes" <<endl;
    else cout <<"No" << endl;
    cout << data[data.size()-1];
    for (int i=data.size()-2; i>=0; i--)
        cout << " " <<data[i];
    return 0;
}

Guess you like

Origin blog.csdn.net/weixin_42100456/article/details/108960575