PAT-1024 Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

note

High precision, judge the number of palindrome, use the stack to judge, first push half of the number into the stack, if it is an odd number, ignore it, and finally judge whether the stack is empty

Code

#include <iostream>
#include <string.h>
#include <stack>
using namespace std;

int tempa[500];
int tempb[500];
int tempc[500];
// 判断是否为回文数
bool is_Palindromic_number(string n)
{
    
    
    stack<char> s;
    // 先将一半的数字进栈
    int i;
    for (i = 0; i < n.size() / 2; i++)
    {
    
    
        s.push(n[i]);
    }
    if (n.size() % 2 == 1)
        i++; // 奇数,跳过最中间的数
    for (int j = i; j < n.size(); j++)
    {
    
    
        if (n[j] == s.top())
            s.pop();
    }
    return s.size() == 0 ? true : false;
}

string add_num(string a)
{
    
    
    memset(tempa, 0, sizeof(tempa));
    memset(tempb, 0, sizeof(tempb));
    memset(tempc, 0, sizeof(tempc));

    int index = 0;
    for (int i = 0; i < a.size(); i++)
    {
    
    
        // 注意转换成数字
        tempa[index] = a[a.size() - i - 1]-'0';
        tempb[index] = a[i]-'0';
        index++;
    }
    // for (int i=0; i<index; i++){
    
    
    //     cout << tempa[i] << "  ||  " << tempb[i] << endl;
    // }
    int indexc = 0;
    for (int i = 0; i < a.size(); i++)
    {
    
    
        tempc[indexc] += tempa[i] + tempb[i];
        // cout << "all:" << tempc[indexc] << "个位为:";
        tempc[indexc+1] = tempc[indexc] / 10;
        tempc[indexc] = tempc[indexc] % 10 ;
        // cout << tempc[indexc] << "下一位为:" << tempc[indexc+1] << endl;
        indexc++;
    }
    if (tempc[indexc] == 0) indexc--;
    string res = "";
    for(int i=indexc; i>=0; i--){
    
    
        res += to_string(tempc[i]);
    }
    return res;
}

// 本地都精度超过Long long 型了
int main()
{
    
    
    int k;
    string n;
    cin >> n >> k;
    if (is_Palindromic_number(n))
    {
    
    
        cout << n << endl;
        cout << 0 << endl;
        return 0; // 忘记return
    }
    string temp;
    for (int i = 0; i < k; i++)
    {
    
    
        temp = add_num(n);
        // cout << temp << endl;
        if (is_Palindromic_number(temp)){
    
    
            cout << temp << endl;
            cout << i+1 <<endl;
            return 0;
        }
        else{
    
    
            n = temp;
        }
    }
    cout << temp << endl;
    cout << k <<endl;
    return 0;
}

Guess you like

Origin blog.csdn.net/weixin_42100456/article/details/109566183
Recommended