1024 Palindromic Number (25 minutes) (plus a simple simulation of Large Numbers)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

 

via
through, through, through

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
const int N=105;
char a[N],b[N],c[N];
void add(char a[],char b[],char ans[]){//a+b=ans
	int la=strlen(a+1);
	int lb=strlen(b+1);
	int tot=0;
	int tmp=0;//进位 
	int ta=la,tb=lb;
	while(ta>0&&tb>0){
		int cnt=(a[ta]-'0')+(b[tb]-'0')+tmp;
		c[++tot]=cnt%10+'0';
		tmp=cnt/10; 
		ta--;tb--;
	}
	while(ta>0){
		int cnt=(a[ta]-'0')+tmp;
		c[++tot]=cnt%10+'0';
		tmp=cnt/10; 
		ta--;
	}
	while(tb>0){
		int cnt=(b[tb]-'0')+tmp;
		c[++tot]=cnt%10+'0';
		tmp=cnt/10; 
		tb--;
	}
	if(tmp>0) c[++tot]=tmp+'0';
	int cnt=0;
	for(int i=tot;i>0;i--){
		ans[++cnt]=c[i];
	}
	ans[++cnt]='\0';
}
bool equal(char a[],char b[]){
	int la=strlen(a+1);
	int lb=strlen(b+1);
	if(la!=lb) return false;
	for(int i=1;i<=la;i++){
		if(a[i]!=b[i]) return false;
	}
	return true;
}
int main(){
	int k;
	scanf("%s",a+1);
	scanf("%d",&k); 
	int step=0;
	bool flag=false;
	while(step<k&&!flag){
		int cnt=0;
		int la=strlen(a+1);
		for(int i=la;i>=1;i--) b[++cnt]=a[i];
		b[++cnt]='\0';
		if(equal(a,b)){
			flag=true;
			break;
		}
		else{
			add(a,b,a);
			step++;
		}
	}
	printf("%s\n%d\n",a+1,step);
	return 0;
}






 

Published 415 original articles · won praise 47 · views 40000 +

Guess you like

Origin blog.csdn.net/qq_42936517/article/details/102814030