(The last day of the Games it ~) 1024 Palindromic Number (25 points)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Writing the same forward or backward figures referred palindromic numbers . For example, 1234321 is a palindrome number. All single digit numbers are palindromes.

Non-palindromic numbers can be paired with a series of operations by the digital palindrome. First, the reversal of non-palindromic number, and add the result to the original number. If the result is not a palindrome number, then repeat the process until it is given palindrome. For example, if we start from the 67, we can get two steps palindrome: 67 + 76 = 143, 143 + 341 = 484.

Given any positive integer  N , you should find its counterpart palindrome number of steps and find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Palindrome judgment given number, output is 0 times it is not the sum has been flipped more than a given number of times, the output of a given number of flip result and outputs the sum of a given number of times, found in a given frequency output the number and frequency.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
#include<iostream>
#include<algorithm>
using namespace std;
string n;///大整数n以字符串形式输入
void add(string t)
{///大整数相加
    int len=n.length(),cnt=0;///cnt进位
    for(int len-1;i>=0;i--)
    {
        n[i]=n[i]+t[i]+cnt-'0';///第一位开始正向相加
        cnt=0;///每次相加后进位都得归0
        if(n[i]>'9')
        {
            n[i]-=10;
            cnt=1;///进一位
        }
    }
    if(cnt)n+='1';///还有进位就在右边加1
    reverse(n.begin(),n.end());///倒置后才是正常结果
}
int main()
{
    int k,i;
    cin>>n>>k;
    for(i=0;i<=k;i++)
    {
        string t=n;///复制字符串
        reverse(t.begin(),t.end());///翻转验证回文
        if(n==t||i==k)break;///找到或者到给定次数没找到都要退出
        add(t);///没找到继续找(传入的是翻转后的n)
    }
    cout<<n<<endl<<i;///输出和,次数
}

 

 

Guess you like

Origin blog.csdn.net/qq_43813697/article/details/90286960