PAT Class 1019 General Palindromic Number (hex conversion, vector to use, beginning two test points have not seen)

1019 General Palindromic Number (20 分)
 

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits ai​​ as (. Here, as usual, 0 for all i and ak​​ is non-zero. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​​ ak1​​ ... a0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

Outline of Solution
  Title effect: Given a N and b, b in the N-ary seeking, whether it is a palindrome (Palindromic number). Where, 0 <N, b <= 10 ^ 9.
  Using int sufficient basic types, followed by binary conversion, to note that, B is relatively large band, a number of units is not possible to obtain, for example 10 to 15 in hexadecimal. You may be stored with a char, and then compared. Or also compares the row with a two-dimensional array of.

But later found with char, Digital + '0' may be out of range ascii representation, there is a test point is to make life difficult.

The final selection vector <int>, very convenient.

 

A typical test case:

6817 16
Yes
1 10 10 1
187 521 254  1000000 
No. 
187  521 254

AC Code:

#include<bits/stdc++.h> 
using namespace std;
int main(){
    int d,b;
    cin>>d>>b;
    char s[1005];
    int k=1;
    while(d>0){
        s[k++]=d%b+'0';
        //cout<<d%b<<endl;
        d=d/b;
    }
    k--; 
    //cout<<d<<endl;
    int middle=int((1+k)/2);
    int f=1;
    for(int i=1;i<=middle;i++){
        if(s[i]!=s[k+1-i]){
            f=0;
            break;
        }
    }
    if(f){
        cout<<"Yes"<<endl;
    }else{
        cout<<"No"<<endl;
    }
    for(int i=k;i>=. 1 ; i-- ) { 
        COUT << S [I] - ' 0 ' ; // may radix b is relatively large, so to -'0 'output 
        IF (I =! . 1 ) { 
            COUT << "  " ; 
        } 
    } 
    return  0 ; 
}

 

 

 

Guess you like

Origin www.cnblogs.com/caiyishuai/p/11329822.html