判断素数

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.

Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by “yes” or “no”.

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes
#include<iostream>
using namespace std;
bool is_prime(int n){
    if(n<=2)return false;
    for(int i=2;i*i<=n;i++){
        if(n%i==0)return false;
    }
    return true;
}
int main(){
    int n;
    int num=0;
    while(cin>>n){
        if(n<=0)break;
        num++;
        if(is_prime(n)==true)
            cout<<num<<":"<<" "<<"yes"<<endl;
        else
            cout<<num<<":"<<" "<<"no"<<endl;

    }
} 

猜你喜欢

转载自blog.csdn.net/oceansidexue/article/details/80258020