对于给定的一个字符串,统计其中数字字符出现的次数。c++

对于给定的一个字符串,统计其中数字字符出现的次数

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。对于每个测试实例,输出该串中数值的个数,每个输出占一行。

sample input:
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

sample output:
6
9

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()	
{
	int n;
	cin>>n;
	while(n--)
	{
		char str[300];
		cin>>str;
		int len=strlen(str);
		int sum=0;
		for(int i=0;i<len;i++)
		{
			if(str[i]<'A')
				sum++;
		}
		cout<<sum<<endl;
	}
	return 0;
}

由于数字的asic码都比‘A’小,所以判断条件可以是str[i]<‘A’,当然也可以使用(str[i]>=‘0’&&str[i]<=‘9’)来完成对数字的判断。

发布了29 篇原创文章 · 获赞 1 · 访问量 967

猜你喜欢

转载自blog.csdn.net/qq_44654498/article/details/104446594
今日推荐