浙大版《Python 程序设计》题目集第七章答案(自用)

第7章-1 词频统计 (30分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

      
    

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

答案:


import sys
flag = 1
str1 = ""
while flag == 1:
    s=sys.stdin.readline()
    for i in s:
        if i == "#":
            flag = 0
        else:
            str1 += i 
t = set()
for i in str1:
    if i.isalnum()==False and i!= "_":
        t.add(i)
for i in t:
    str1=str1.replace(i," ")
list1 = str1.split()
list2 = []
for i in list1:
    if i != "":
        if len(i) > 15:
            list2.append(i[:15].lower())
        else:
            list2.append(i.lower())

dic = {}
for i in list2:
    dic[i]=dic.get(i,0)+1
ans = sorted(dic.items(),key=lambda x:(-x[1],x[0]))
print(len(ans))
m = int(0.1*len(ans))
for i in range(0,m):
    str2 = ""
    str2 += str(ans[i][1]) + ":" + ans[i][0]
    print(str2)
发布了21 篇原创文章 · 获赞 0 · 访问量 479

猜你喜欢

转载自blog.csdn.net/qq_39901722/article/details/104718778
今日推荐