POJ 1251-Jungle Roads(最小生成树)

Jungle Roads

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38773 Accepted: 18244

Description

在这里插入图片描述
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

有一个旅游区,旅游区有很多的景点,景点间需要开通缆车,使得任意两个景点可以互相到达。现在给出一些点间的缆车线路制造成本,两个景点之间可能有多重制造方式。问最少的花费是多少。

Input
输入包括多组数据,最多100组,最后以输入0表示结束。
对于每一组数据,第一行一个n,表示景区数量。1<n<27
之后n-1行,每行第一个是一个大写字母,表示当前景区的编号,接着是k,表示当前景区对外可以有k中缆车线路制造方式,接着k对,每对第一个是一个字母,表示这条路线连接的景区,第二个是一个数字,表示制造成本。0<=k<=15。最多75条制造线路,每条线路的制造成本最大是100。

Output
对于每一组数据,输出一行表示最小成本。

Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output
216
30

题目链接

题目大意:旅游区有很多的景点,景点间需要开通缆车,使得任意两个景点可以互相到达,每个缆车都需要成本,求把整个旅游区连通最下的成本是多少。

解题思路:这是POJ上的一道最小生成树的变形,它的城市是用26个字母代替的,其他不变,所以用克鲁斯卡尔算法和普利姆算法都可以解题。AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <map>
using namespace std;
const int N=30;
const int inf=0x3f3f3f3f;
int book[N],dis[N];
int mp[N][N];
int n;
int main()
{
	ios::sync_with_stdio(false);
	void prim();
	while(cin>>n&&n)
	{
	    char ch,ch1;
	    int k,len;
	    for(int i=1;i<=n;i++)
	      for(int j=1;j<=i;j++)
	        if(i==j)
	          mp[i][j]=0;
	        else
			  mp[i][j]=mp[j][i]=inf;
        for(int i=1;i<n;i++)
        {
        	cin>>ch>>k;
	    	for(int j=1;j<=k;j++)
	    	{
	    		cin>>ch1>>len;
	    		mp[ch-'A'+1][ch1-'A'+1]=mp[ch1-'A'+1][ch-'A'+1]=len;//这一步把字符型的城市全转换为数字型的城市
			}
		}
		memset(book,0,sizeof book);
		for(int i=1;i<=n;i++)
		  dis[i]=mp[1][i];
		book[1]=1;
		prim();
		int sum=0;
		for(int i=1;i<=n;i++)
		  sum+=dis[i];
		cout<<sum<<endl;  
	}
	return 0;
}
void prim()
{
	int cnt=1;
	int i,j,k;
	while(cnt<n)
	{
		int min=inf;
		for(i=1;i<=n;i++)
		{
			if(!book[i]&&dis[i]<min)
			{
				min=dis[i];
				j=i;
			}
		}
		book[j]=1;
		cnt++;
		for(k=1;k<=n;k++)
		{
			if(!book[k]&&dis[k]>mp[j][k])
			  dis[k]=mp[j][k];
		}
	}
}
发布了34 篇原创文章 · 获赞 0 · 访问量 788

猜你喜欢

转载自blog.csdn.net/aezakmias/article/details/104727967
今日推荐