ZOJ 3261 Connections in Galaxy War 并查集删边

一、内容

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

    "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

二、思路

在这里插入图片描述

三、代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
const int N = 1e4 + 5, M = 2e4 + 5, Q = 5e4 + 5;
struct E {
	int x, y;
} e[M];
struct Qu {
	int x, y;
	char s[8];
} q[Q]; 
int n, m, k, mw[N], ok, w[N], id[N], p[N], ans[Q];
map<pair<int, int>, int> mp;
int find(int x) {
	return x == p[x] ? x : (p[x] = find(p[x]));
}
void merge(int x, int y) {
	int fx = find(x), fy = find(y);
	if (fx == fy) return;
	p[fx] = fy;
	if (mw[fy] < mw[fx]) {
		mw[fy] = mw[fx]; id[fy] = id[fx];
	} else if (mw[fy] == mw[fx]) id[fy] = min(id[fx], id[fy]);//相等权取号较小的 
}
int main() {
	while (~scanf("%d", &n)) {
		mp.clear();
		for (int i = 0; i < n; i++) {
			scanf("%d", &w[i]);
			p[i] = id[i] = i;
			mw[i] = w[i];
		}
		scanf("%d", &m);
		for (int i = 1; i <= m; i++) scanf("%d%d", &e[i].x, &e[i].y);
		scanf("%d", &k);
		for (int i = 1; i <= k; i++) {
			scanf("%s", q[i].s);
			if (q[i].s[0] == 'q') scanf("%d", &q[i].x);
			else {
				scanf("%d%d", &q[i].x, &q[i].y);
				mp[make_pair(q[i].x, q[i].y)] = 1;
				mp[make_pair(q[i].y, q[i].x)] = 1;
			}
		}
		//把没有删除的边建好 
		for (int i = 1; i <= m; i++) {
			int x = e[i].x, y = e[i].y;
			if (!mp[make_pair(x, y)]) merge(x, y);
		}
		//方向遍历 进行加边 
		int cnt = 0;
		for (int i = k; i >= 1; i--) {
			int x = q[i].x, y = q[i].y;
			if (q[i].s[0] == 'd') merge(x, y);
			else {
				int fx = find(x);
				if (mw[fx] > w[x]) ans[++cnt] = id[fx];
				else ans[++cnt] = -1;
			}
		}
		if (ok) printf("\n");
		ok = 1; 
		for (int i = cnt; i >= 1; i--) printf("%d\n", ans[i]);
	}
	return 0;
}
发布了486 篇原创文章 · 获赞 496 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104616318