自测-5 Shuffling Machine (20分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …,D13,
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2 36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6
7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33
34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10
H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7
C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

解题思路:
这里边第一个考点是Shuffle过程,因为我们之前学过MapReduce,里面也有这个Shuffle过程,Shuffle的正常意思是洗牌或弄乱,可能大家更熟悉的是Java API里的Collections.shuffle(List)方法,它会随机地打乱参数list里的元素顺序。这道题的意思也是将扑克牌按照么一种特定顺序洗多次,使得扑克牌的顺序被打乱,然后就让我们求打乱后的牌的顺序。
可以将扑克牌拆分,字母:S、C、D、J。数字:1—13。三个整型数组分别存放:0–53个数字、洗牌的顺序、洗后的顺序,洗后字母的确定方法:用其对13整除,根据除数,判断花色,输出即可,洗后数字的确定方法:将其值对13求余,即可算出数字,然后拼接输出即可。

代码:

#include <stdio.h>
#include <stdlib.h>

int c[600];
int a[600];
int b[600];

//a[]:S1,S2...   b[]:6,32...  c[]:ans
void shuffle()//洗牌过程
{
    int i,t;
    for(i=1; i<55; i++)
    {
        t = b[i];
        c[t] = a[i];
    }
    for(i=1; i<55; i++)
    {
        a[i] = c[i];
    }
}

void card_init()
{
    int i;
    for(i=1; i<=54; i++)
    {
        a[i] = i;
    }
}

char get_color(int n)
{
    char ch;
    if((n-1)/13 == 0)
    {
        ch = 'S';
    }
    else if((n-1)/13 == 1)
    {
        ch = 'H';
    }
    else if((n-1)/13 == 2)
    {
        ch = 'C';
    }
    else if((n-1)/13 == 3)
    {
        ch = 'D';
    }
    else
    {
        ch = 'J';
    }
    return ch;
}


//36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

int main()
{
    int n,i;
    char ch;
    scanf("%d",&n);
    for(i=1; i<=54; i++)
    {
        scanf("%d",&(b[i]));
    }

    card_init();

    for(i=0; i<n; i++)
    {
        shuffle();
    }

    for(i=1; i<=54; i++)
    {
        ch = get_color(c[i]);
        printf("%c",ch);
        printf("%d",(c[i])%13==0?13:(c[i])%13);
        if(i != 54)
        {
            printf(" ");
        }
    }

    return 0;
}

运行结果:
运行结果

扫描二维码关注公众号,回复: 9322316 查看本文章
发布了24 篇原创文章 · 获赞 11 · 访问量 3201

猜你喜欢

转载自blog.csdn.net/qq_44292472/article/details/104431675