PAT甲级 1115 Counting Nodes in a BST (30 分) 二刷 (构建BST+树的层次遍历)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
struct node{
    int data;
    node *lchild,*rchild;
    int level;
};
void insert_BST(node* &curr,int a)
{
    if(curr==NULL)
    {
        curr=new node;
        curr->data=a;
        curr->lchild=NULL;
        curr->rchild=NULL;
        return;
    }
    if( a<=curr->data )
        insert_BST(curr->lchild,a);
    else
        insert_BST(curr->rchild,a);
}
int deepest;
int num[1005]={0};
void level_tra(node *root)
{
    queue<node*> que;
    if(root==NULL)
        return;
    root->level=0;
    que.push(root);
    while(!que.empty())
    {
        node* curr=que.front();
        que.pop();
        deepest=curr->level;
        num[ curr->level ]++;
        if(curr->lchild)
        {
            curr->lchild->level = curr->level + 1;
            que.push(curr->lchild);
        }
        if(curr->rchild)
        {
            curr->rchild->level = curr->level + 1;
            que.push(curr->rchild);
        }
    }
}
int main(){
    int N,i,a,b;
    cin>>N;
    node *root=NULL;
    for(i=0;i<N;i++)
    {
        scanf("%d",&a);
        insert_BST(root,a);
    }
    level_tra(root);
    a=num[deepest],b=num[deepest-1];
    printf("%d + %d = %d\n",a,b,a+b);
    return 0;
}
发布了174 篇原创文章 · 获赞 18 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_41173604/article/details/100513560