CF1288B-Yet Another Meme Problem

Description

Try guessing the statement from this picture http://tiny.cc/ogyoiz.

You are given two integers A and B, calculate the number of pairs (a,b) such that 1≤a≤A, 1≤b≤B, and the equation a⋅b+a+b=conc(a,b) is true; conc(a,b) is the concatenation of a and b (for example, conc(12,23)=1223, conc(100,11)=10011). a and b should not contain leading zeroes.

Input

The first line contains t (1≤t≤100) — the number of test cases.

Each test case contains two integers A and B (1≤A,B≤109).

Output

Print one integer — the number of pairs (a,b) such that 1≤a≤A, 1≤b≤B, and the equation a⋅b+a+b=conc(a,b) is true.

Sample Input

3
1 11
4 2
191 31415926

Sample Output

1
0
1337

核心思想:

a⋅b+a+b=conc(a,b)
==>a·b+a=a*10w(上式两侧同减b,w为b的位数)
==>b+1=10w(上式两侧同除a)
由上式可以看出,b为10w-1,例如9,99,999,9999……
a无限制条件。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
	int T;
	ll a,b;
	cin>>T;
	while(T--)
	{
		scanf("%lld%lld",&a,&b);
		ll sum=0,t=9;
		while(t<=b)
		{
			sum++;
			t=t*10+9; 
		}
		printf("%lld\n",a*sum);
	}
	return 0;
}
发布了144 篇原创文章 · 获赞 135 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Nothing_but_Fight/article/details/103983547