POJ--2524 Ubiquitous Religions

Ubiquitous Religions

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7

本题题意:首先输入两个数分别代表学生人数n和询问次数m,接下来m行每行询问两个学生是否在同一个集合,然后统计总的集合数(学生编号从1开始)。

本题思路:就是用并查集完成集合合并,将相同信仰的学生合并为一个集合,没有描述的学生即单独在一个集合内。

AC代码如下:

#include<iostream>
using namespace std;
const int maxn = 5e4 + 5;
int par[maxn];
void init(int n)
{
	for (int i = 1; i <= n; i++)
		par[i] = i;
	
}

int find(int x)
	{

	if (par[x] != x)x = find(par[x]);
		return par[x];
}

void unite(int x, int y)
	{
	x = find(x);
	y = find(y);
	par[x] = y;
}


int main()
{
	int n, m;
	int t1=1;
	while (cin >> n >> m&&n)
	{
		init(n);
		for (int i = 1; i <= m; i++)
		{
			int x, y;
			cin >> x >> y;
			unite(x, y);
		}
		int num = 0;
		for (int i = 1; i <= n; i++)
		{
			if (par[i] == i)num++;
		}
		//Case 1: 
		cout <<"Case "<<t1++<<": "<< num << endl;
	}
	return 0;
}
发布了40 篇原创文章 · 获赞 10 · 访问量 2565

猜你喜欢

转载自blog.csdn.net/lsdstone/article/details/101346213