【简单】All in All

描述

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

输入

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

输出

For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.

样例输入

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

样例输出

Yes
No
Yes
No

题目来源

ULM 2002

分析:
1、字符串a是字符串b的子串即可,不要求完全连续。
2、本来考虑的更复杂一点,翻译之后发现还是简单的。
代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s1,s2;
    while(cin>>s1>>s2)
    {
        int l1=s1.length(),l2=s2.length();
        int t1=0,t2=0;
        for (;t2<l2;)
        {
            if (s1[t1]==s2[t2])
            {
                t1++,t2++;
                if (t1==l1)//所有相同。
                {
                    cout<<"Yes"<<endl;
                    break;
                }
            }
            else
            {
                t2++;
                if (t2==l2)//存在不相同
                {
                    cout<<"No"<<endl;
                    break;
                }
            }
        }
    }
    return 0;
}

发布了122 篇原创文章 · 获赞 0 · 访问量 4658

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104157706
ALL