C 语言 Fractal 打印

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.

A box fractal is defined as below :

  • A box fractal of degree 1 is simply
    X
    
  • A box fractal of degree 2 is
    X X
     X
    X X
    
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)          B(n - 1)
             B(n - 1)
    B(n - 1)          B(n - 1)
    

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer -1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case. Don't output any trailing spaces at the end of each line, or you may get an 'Presentation Error'!

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
   X X                X X
    X                  X
   X X                X X
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
   X X                X X
    X                  X
   X X                X X
X X   X X          X X   X X
 X     X            X     X
X X   X X          X X   X X
#include <stdio.h>
#include <math.h>
#include <string.h>
char mp[100][100];
void fractal(int n,int x,int y){
    int size;
    if(n==1){
        mp[x][y]='x';
        return;
    }
    size=pow(3,n-2);
    fractal(n-1,x,y);
    fractal(n-1,x,y+2*size);
    fractal(n-1,x+size,y+size);
    fractal(n-1,x+2*size,y);
    fractal(n-1,x+2*size,y+2*size);
}


int main(void)
{
   int n,i,j,size;
   scanf("%d",&n);
   size=pow(3,n-1);
   memset(mp,' ',sizeof(mp));
   fractal(n,1,1);
   for(i=1;i<=size;i++){
    for(j=1;j<=size;j++){
        printf("%c",mp[i][j]);
    }
    printf("\n");
   }
}

发布了118 篇原创文章 · 获赞 85 · 访问量 48万+

猜你喜欢

转载自blog.csdn.net/c_lanxiaofang/article/details/103504438