1052 Linked List Sorting (25分) 最后一个测试点遇到段错误 +别人的代码

1052 Linked List Sorting (25分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

遇到段错误,检查了下也没越界,sort里的cmp函数也写的很清楚。

后来,发下,这是一个边界情况,当所有节点都为无效时,要输出0 -1.

#include<iostream>
#include<map>
#include<vector> 
#include<algorithm>
using namespace std;
struct node{
	int add,d,next;
};
int cmp(node x,node y)
{
	return x.add<y.add;
}
int main()
{
	int i,j,td,tn,ts,n,len;
	node t;
	map<int,node> s;
	map<int,node>::iterator it;
	vector<node> a;
	a.clear();
	s.clear();
	cin>>n>>ts;
	for(i=0;i<n;i++)
	{
		cin>>t.add>>t.d>>t.next;
		s.insert(make_pair(t.add,t));
	}
	for(;ts!=-1;)
	{
		if(s.count(ts))
		{
			it=s.find(ts);
			a.push_back(it->second);
			ts=s[ts].next;
		}
		else
		{
			break;
		}
		
	}
	if(a.size()==0)
	{
		cout<<"0 -1"<<endl;
		return 0;
	}
	sort(a.begin(),a.end(),cmp);
	len=a.size();
	printf("%d %05d\n",len,a[0].add);
	
	for(i=0;i<len;i++)
	{
		if(i!=len-1)
		printf("%05d %d %05d\n",a[i].add,a[i].d,a[i+1].add);
		else
		printf("%05d %d -1\n",a[i].add,a[i].d);
	}
	return 0;
 } 

别人的代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
struct NODE {
 int address, key, next;
 bool flag;
}node[100000];
vector< NODE > v ;
int cmp1(  NODE a, NODE b ) {
    return a.key < b.key;
}
int main() {
 int n, cnt = 0, s, a, b, c;
 scanf("%d%d", &n, &s);
 for( int i = 0; i < n; i++) {
      scanf("%d%d%d", &a, &b, &c);
      node[a] = {a, b, c, false};
 }
 for( int i = s; i != -1; i = node[i].next) {
      v.push_back( node[i] );
      cnt++;
 }
 if( cnt == 0) {
     printf("0 -1");
 } else {
 sort(v.begin(), v.end(), cmp1);
 printf("%d %05d\n", cnt, v[0].address);
 for( int i = 0; i < cnt; i++) {
      printf("%05d %d ", v[i].address, v[i].key);
      if( i != cnt - 1)
          printf("%05d\n", v[i + 1].address);
      else
          printf("-1\n");
 } 
 }
 return 0;
}
发布了374 篇原创文章 · 获赞 101 · 访问量 21万+

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/103490662