1091 Acute Stroke (30分) 最后两个测试点报错

1091 Acute Stroke (30分)

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M×N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

figstroke.jpg

Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26

最后两个报错原因:

数组大小开错了

如果要用dfs,会出现段错误。

所以用bfs

有点很重要:

连通块的体积要是小于t的话,那他曾经访问过(设置vis为true)的位置就不能被访问了,这是一个小问题。

我的解决办法是:

	if(ans>=t)
					cnt+=ans;
					else
					{
			
						while(!ts.empty()){
							temp=ts.front();
							vis[temp.x][temp.y][temp.z]=false;
							ts.pop();
						}
					}

找一个队列,存它曾经访问过的块,如果体积小于t,就把块里所有元素设置false。

代码:

#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
	int x,y,z;
};
node temp,t1;
queue<node> ts;
int xx[6]={0,0,0,0,1,-1};
int yy[6]={0,0,1,-1,0,0};
int zz[6]={1,-1,0,0,0,0};
int  map[60][1286][128];
int  vis[60][1286][128];
int ans=0,cnt=0,m,n,l,t;
int judge(int x,int y,int z){
	if(x<0||x>=l||y<0||y>=m||z<0||z>=n)
	return 0;
	if(map[x][y][z]==0||vis[x][y][z])
	return 0;
	if(map[x][y][z]==1)
	return 1;
	else
	return 0;
}
void bfs(int tx,int ty,int tz){
	int i,j,k;
	queue<node> s;
	while(!ts.empty()){
		ts.pop();
	}
    temp.x=tx;
    temp.y=ty;
    temp.z=tz;
    vis[temp.x][temp.y][temp.z]=true;
    s.push(temp);
    ts.push(temp);
    while(!s.empty()){
    	temp=s.front();
    	s.pop();
    	for(i=0;i<6;i++)
    	{
    		int x=temp.x+xx[i];
    		int y=temp.y+yy[i];
    		int z=temp.z+zz[i];
    		if(judge(x,y,z)){
    				
    			vis[x][y][z]=true;
    			ans++;
    			t1.x=x;
    			t1.y=y;
    			t1.z=z;
    			s.push(t1);
    			ts.push(t1);
			}
		}
	}
}
int main(){
	
	int i,j,k;
	scanf("%d %d %d %d",&m,&n,&l,&t);
	for(i=0;i<l;i++)
	{
		for(j=0;j<m;j++)
		{
			for(k=0;k<n;k++){
				scanf("%d",&map[i][j][k]);
				vis[i][j][k]=false;
				
			}
		}
	}
	for(i=0;i<l;i++)
	{
		for(j=0;j<m;j++)
		{
			for(k=0;k<n;k++){
				
				if(map[i][j][k]&&vis[i][j][k]==false){
					ans=1;
					bfs(i,j,k);
					if(ans>=t)
					cnt+=ans;
					else
					{
			
						while(!ts.empty()){
							temp=ts.front();
							vis[temp.x][temp.y][temp.z]=false;
							ts.pop();
						}
					}
					
					ans=0;
				}
			}
			
		}
	}
	printf("%d\n",cnt);
	return 0;
} 
发布了374 篇原创文章 · 获赞 101 · 访问量 21万+

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/103977001