Greedy Gift Givers

Greedy Gift Givers

A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to some or all of the other friends (although some might be cheap and give to no one). Likewise, each friend might or might not receive money from any or all of the other friends. Your goal is to deduce how much more money each person receives than they give.

The rules for gift-giving are potentially different than you might expect. Each person goes to the bank (or any other source of money) to get a certain amount of money to give and divides this money evenly among all those to whom he or she is giving a gift. No fractional money is available, so dividing 7 among 2 friends would be 3 each for the friends with 1 left over – that 1 left over goes into the giver’s “account”. All the participants’ gift accounts start at 0 and are decreased by money given and increased by money received.

In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.

Given:
• a group of friends, no one of whom has a name longer than 14 characters,
• the money each person in the group spends on gifts, and
• a (sub)list of friends to whom each person gives gifts,determine how much money each person ends up with.

IMPORTANT NOTE

The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as ‘\n’. This differs from Windows, which ends lines with two characters, ‘\n’ and ‘\r’. Do not let your program get trapped by this!

INPUT FORMAT

在这里插入图片描述

SAMPLE INPUT (file gift1.in)

5
dave
laura
owen
vick
amr
dave
200 3
laura
owen
vick
owen
500 1
dave
amr
150 2
vick
owen
laura
0 2
amr
vick
vick
0 0

OUTPUT FORMAT

The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed in the same order they appear starting on line 2 of the input.

All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given is kept by the giver.

SAMPLE OUTPUT (file gift1.out)

dave 302
laura 66
owen -359
vick 141
amr -150

OUTPUT EXPLANATION

在这里插入图片描述

C++编写

最初是以为它有可能测试给出来的取钱来分钱的人小于NP,后面用for循环写出来也能过,说明NP个人都会写出来,代码如下:

/*
ID: your_id_here
TASK: gift1
LANG: C++                 
*/
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
const int MAX_NP=15;

struct fri{
    string name;
    int money;
}friends[MAX_NP];

int main()
{
    freopen("gift1.in","r",stdin);
    freopen("gift1.out","w",stdout);
    int np;
    cin>>np;
    for(int i=0;i<np;i++)
    {
        cin>>friends[i].name;
        friends[i].money=0;
    }

    string a;
    int mon,num,average;
    while(cin>>a>>mon>>num)
    {
        if(num==0)
        {
            for(int i=0;i<np;i++)
            {
                if(friends[i].name == a)
                {
                    friends[i].money+=mon;
                }
            }
        }
        else
        {
            for(int j=0;j<np;j++)
            {
                if(friends[j].name == a)
                {
                    friends[j].money-=mon;
                    average=mon/num;
                    string fri;
                    for(int k=0;k<num;k++)
                    {
                        cin>>fri;
                        for(int s=0;s<np;s++)
                        {
                            if(friends[s].name == fri)
                            {
                                friends[s].money+=average;
                            }
                        }
                    }

                    if(mon%num != 0)
                        friends[j].money+=mon%num;
                }
            }
        }
    }

    for(int i=0;i<np;i++)
    {
        cout<<friends[i].name<<" "<<friends[i].money<<endl;
    }
}

还有个差不多的代码,换成for循环来写的:

/*
ID: your_id_here
TASK: gift1
LANG: C++                 
*/
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
const int MAX_NP=15;

struct fri{
    string name;
    int money;
}friends[MAX_NP];

int main()
{
    freopen("gift1.in","r",stdin);
    freopen("gift1.out","w",stdout);

    int np;
    cin>>np;
    for(int i=0;i<np;i++)
    {
        cin>>friends[i].name;
        friends[i].money=0;
    }
    
    for(int i=0;i<np;i++)
    {
        string a;
        int mon,num,average;
        cin>>a;
        cin>>mon>>num;

        if(num==0)
        {
            for(int n=0;n<np;n++)
            {
                if(friends[n].name == a)
                {
                    friends[n].money+=mon;
                }
            }
        }
        else
        {
            for(int j=0;j<np;j++)
            {
                if(friends[j].name == a)
                {
                    friends[j].money-=mon;
                    average=mon/num;
                    string fri;
                    for(int k=0;k<num;k++)
                    {
                        cin>>fri;
                        for(int s=0;s<np;s++)
                        {
                            if(friends[s].name == fri)
                            {
                                friends[s].money+=average;
                            }
                        }
                    }

                    if(mon%num != 0)
                        friends[j].money+=mon%num;
                }
            }
        }
    }

    for(int i=0;i<np;i++)
    {
        cout<<friends[i].name<<" "<<friends[i].money<<endl;
    }
}
发布了82 篇原创文章 · 获赞 12 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Slatter/article/details/96049150