Friday the Thirteenth

Friday the Thirteenth

Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400.

Note that the start year is NINETEEN HUNDRED, not NINETEEN NINETY.

There are few facts you need to know before you can solve this problem:

• January 1, 1900 was on a Monday.
• Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
• Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
• The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.
Do not use any built-in date functions in your computer language.

Don’t just precompute the answers, either, please.

INPUT FORMAT

One line with the integer N.

SAMPLE INPUT

20

OUTPUT FORMAT

Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday, Monday, Tuesday, …, Friday.

SAMPLE OUTPUT

36 33 34 33 35 35 34

C++编写:

这道题还是先理一下思路比较好,想好怎么做就可以动手了,注意一下输出格式就好,代码如下:

/*
ID: your_id_here
TASK: friday
LANG: C++                 
*/
#include<iostream>
#include<cstdio>
using namespace std;

int N;
int month_days[12]={31,28,31,30,31,30,31,31,30,31,30,31};
int week[7]={0};                 /*顺序为Saturday, Sunday, Monday, Tuesday, Wednesday, Thursday, Friday. */
int index=0;     /*因为1900年1月13日为星期六 */

bool isLeapYear(int year)
{
    return year % 400 == 0 || (year % 4 == 0 && year % 100 != 0); 
}

void solve()
{
    for(int i=1900;i<1900+N;i++)
    {
        month_days[1]=isLeapYear(i)?29:28;  
        for(int j=0;j<12;j++)
        {
            week[index]++;
            index+=month_days[j];            /*两个月同一个日子相隔的天数为上一个月的总天数 */
            index%=7;
        }
    }
    for(int k=0;k<6;k++)
        cout<<week[k]<<" ";
    cout<<week[6]<<endl;
}

int main()
{
    freopen("friday.in","r",stdin);
    freopen("friday.out","w",stdout);

    cin>>N;
    solve();
}
发布了82 篇原创文章 · 获赞 12 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Slatter/article/details/96217528