HDU 1.3.8 Who's in the Middle

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 


Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 
Input
* Line 1: A single integer N 


* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 
Output
* Line 1: A single integer that is the median milk output.
 
Sample Input
5
2
4
1
3
5
 
Sample Output
3


<div style="" font-size:="" 14px;="" border-top:="" #b7cbff="" 1px="" dashed;="" font-family:="" times"="">
Hint
 
INPUT DETAILS: 


Five cows with milk outputs of 1..5 


OUTPUT DETAILS: 


1 and 2 are below 3; 4 and 5 are above 3.
 
 
Source
USACO 2004 November
 
Recommend
mcqsmall
 


题目有点坑,没说清楚有多组测试数据。。其实就是水题一道。
#include<stdio.h>  
#include"algorithm"  
using namespace std;  
int cowOutput[10000];  
int cmp(int a, int b)  
{  
    return a < b;  
}  
int main()  
{  
    int cowAmount;  
    while (scanf("%d", &cowAmount) != EOF)  
    {  
        for (int i = 0; i < cowAmount; i++)  
            scanf("%d", &cowOutput[i]);  
        sort(cowOutput, cowOutput + cowAmount, cmp);  
        printf("%d\n", cowOutput[cowAmount / 2]);  
    }  
    return 0;  
}  

发布了70 篇原创文章 · 获赞 17 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/hwj_wayne/article/details/50849015