zoj 4035 J - Doki Doki Literature Club【优先队列+map】

Doki Doki Literature Club! is a visual novel developed by Team Salvato. The protagonist is invited by his childhood friend, Sayori, to join their high school's literature club. The protagonist then meets the other members of the club: Natsuki, Yuri, and the club president Monika. The protagonist starts to participate in the club's activities such as writing and sharing poetry, and grows close to the four girls. What a lovely story!

A very important feature of the game is its poetry writing mechanism. The player is given a list of various words to select from that will make up his poem. Each girl in the Literature Club has different word preferences, and will be very happy if the player's poem is full of her favorite words.

The poem writing mini-game (from wikipedia)

BaoBao is a big fan of the game and likes Sayori the most, so he decides to write a poem to please Sayori. A poem of words is nothing more than a sequence of strings, and the happiness of Sayori after reading the poem is calculated by the formula

where is the happiness and is Sayori's preference to the word .

Given a list of words and Sayori's preference to each word, please help BaoBao select words from the list and finish the poem with these words to maximize the happiness of Sayori.

Please note that each word can be used at most once!


Input

There are multiple test cases. The first line of input contains an integer (about 100), indicating the number of test cases. For each test case:

The first line contains two integers and (), indicating the number of words and the length of the poem.

For the following lines, the -th line contains a string consisting of lowercased English letters () and an integer (), indicating the -th word and Sayori's preference to this word. It's guaranteed that for all .

Output

For each test case output one line containing an integer and strings separated by one space, indicating the maximum possible happiness and the corresponding poem. If there are multiple poems which can achieve the maximum happiness, print the lexicographically smallest one.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

A sequence of strings is lexicographically smaller than another sequence of strings , if there exists a () such that for all and is lexicographically smaller than .

A string is lexicographically smaller than another string , if there exists a () such that for all and , or for all and .

Sample Input
4
10 8
hello 0
world 0
behind 0
far 1
be 2
spring 10
can 15
comes 20
winter 25
if 200
5 5
collegiate 0
programming -5
zhejiang 10
provincial 5
contest -45
3 2
bcda 1
bcd 1
bbbbb 1
3 2
a 1
aa 1
aaa 1
Sample Output
2018 if winter comes can spring be far behind
15 zhejiang provincial collegiate programming contest
3 bbbbb bcd
3 a aa

题意:输出权值最大,字典序最小的序列。

思路:第一次把map和优先队列结合使用,比赛的时候没有给写出来,以为存值得用long long ,我们根本没有想到!!!

#include<stdio.h>
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
const int maxn = 110;
map<string,int>str[maxn];

struct node{
	long long  w;
	string s1;
	bool operator < (const node & ch) const{
		if(w == ch.w)
			return ch.s1 < s1;
		return w < ch.w;
	}
};

priority_queue<node>q,q2;
void add(string s,int w)
{
	struct node Node;
	Node.s1 = s;
	Node.w = w;
	q.push(Node);
	q2.push(Node);
	return;
}
int main()
{
	int t;
	int n,m,i,j;
	long long w;
	long long sum;
	char s[maxn];
	struct node Node;
	scanf("%d",&t);
	while(t--)
	{
		while(!q.empty())
			q.pop();
		while(!q2.empty())
			q2.pop();
		scanf("%d%d",&n,&m);
		getchar();
		for(i = 0; i < n; i ++)
		{
			scanf("%s %lld",s,&w);
			add(s,w);
		}
		sum = 0;
		for(i = m; i >= 1; i --)
		{
			Node = q.top();
			q.pop();
			sum += i*Node.w ;
		}
		printf("%lld",sum);
		if(!q2.empty())
		{
			Node = q2.top();
			q2.pop();
			cout<<" "<<Node.s1 ;
			for(i = 1; i < m&&!q2.empty(); i ++)
			{
				
				Node = q2.top();
				q2.pop();
				cout<<" "<<Node.s1 ;
			}
		}
		printf("\n");	
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/hello_sheep/article/details/80207603