POJ 3140——Contestants Division【树形DP & 删边 & 点权树 & 树重心变形】

题目传送门


Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?


Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.


Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0


Sample Output

Case 1: 1


Source

Shanghai 2006


题意

给定一棵n棵节点的树,求删去某条边后两个分支的最小差异值。


题解

  • node_val[u] 表示以u点为根节点的子树的总人数,那么不在该子树的人数和为 sum-node_val[u]
    dfs遍历一遍即可。
  • 其实就是个树重心变形,拿重心板子改一改就AC了

AC-Code

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <fstream>
#include <utility>
using namespace std;
typedef long long ll;
typedef pair<int, int> Pii;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
ll Abs(ll a) {
	return a > 0 ? a : -a;
}
const ll INF = 0x7fffffff7fffffff;
const int MAXN = 1e6 + 5;
const int MOD = 1e9 + 7;

struct Edge {
	int next;
	int to;
}edge[MAXN << 1];
ll node_val[MAXN];
int head[MAXN];
int root;
ll son[MAXN];
ll f[MAXN];
ll sum_val;
int n, k;
int cnt;
void getroot(int now, int fa) {
	son[now] = node_val[now];
	f[now] = 0;
	for (int i = head[now]; ~i; i = edge[i].next) {
		if (edge[i].to == fa)	continue;
		getroot(edge[i].to, now);
		son[now] += son[edge[i].to];
		f[now] = max(f[now], son[edge[i].to]);
	}
	f[now] = max(f[now], sum_val - son[now]);
	if (f[now] < f[root]) {
		root = now;
	}
}
ll ans;
void DP(int now, int fa) {
	for (int i = head[now]; ~i; i = edge[i].next) {
		if (edge[i].to != fa) {
			DP(edge[i].to, now);
			node_val[now] += node_val[edge[i].to];
			ans = min(ans, Abs(sum_val - 2 * node_val[edge[i].to]));
		}
	}
}
void addEdge(int u, int v) {
	edge[cnt].to = v;
	edge[cnt].next = head[u];
	head[u] = cnt++;
}
int main() {
	int a, b;
	int T = 0;
	while (scanf("%d%d", &n, &k), n + k) {
		memset(head, -1, sizeof head);
		cnt = 0;
		sum_val = 0;
		ans = INF;
		for (int i = 1; i <= n; i++) {
			scanf("%lld", &node_val[i]);
			sum_val += node_val[i];
		}
		for (int i = 1; i <= k; i++) {
			scanf("%d%d", &a, &b);
			addEdge(a, b);
			addEdge(b, a);
		}
		DP(1, 0);
		printf("Case %d: %lld\n", ++T, ans);
	/*	这个重心板子方法也可以AC
		root = 0;
		f[root] = INF;
		getroot(1, 0);
		printf("Case %d: %lld\n", ++T, Abs(sum_val - 2 * f[root]));
	*/
	}
	return 0;
}
发布了104 篇原创文章 · 获赞 60 · 访问量 5893

猜你喜欢

转载自blog.csdn.net/Q_1849805767/article/details/103096496