Android中使用getDrawable时提示:Call requires API level 21(current min is 15)

场景

在通过getDrawable方法获取照片资源时提示:

Call requires API level 21(current min is 15)

 

 

注:

博客:
https://blog.csdn.net/badao_liumang_qizhi
关注公众号
霸道的程序猿
获取编程相关电子书、教程推送与免费下载。

实现

这是因为getDrawable方法的最低的API的版本是21,而当前版本要低。

所以在Android Studio中Android视图时找到Gradle Scripts下的build.gradle,要找到自己对应的Module,一个Project下可有多个Module。

双击打开,将最小SDK版本minSdkVersion修改为21,并点击右上角的同步。

 

 

猜你喜欢

转载自www.cnblogs.com/badaoliumangqizhi/p/12194203.html