PAT基础级-钻石段位样卷2-7-4 6翻了 (15 分)

666.JPG

“666”是一种网络用语,大概是表示某人很厉害、我们很佩服的意思。最近又衍生出另一个数字“9”,意思是“6翻了”,实在太厉害的意思。如果你以为这就是厉害的最高境界,那就错啦 —— 目前的最高境界是数字“27”,因为这是 3 个 “9”!

本题就请你编写程序,将那些过时的、只会用一连串“6666……6”表达仰慕的句子,翻译成最新的高级表达。

输入格式:

输入在一行中给出一句话,即一个非空字符串,由不超过 1000 个英文字母、数字和空格组成,以回车结束。

输出格式:

从左到右扫描输入的句子:如果句子中有超过 3 个连续的 6,则将这串连续的 6 替换成 9;但如果有超过 9 个连续的 6,则将这串连续的 6 替换成 27。其他内容不受影响,原样输出。

输入样例:

it is so 666 really 6666 what else can I say 6666666666

输出样例:

it is so 666 really 9 what else can I say 27


#include <iostream>
using namespace std;
int main()
{
    string str,res="";
    getline(cin,str);
    for(int i=0;i<str.length();)
        if(str[i]!='6') {
            res+=str[i];
            i++;
        }
        else{
            int count_=1;
            while(++i<str.length()&&str[i]=='6')
                count_++;
            if(count_<=3)
                while(count_--) res+='6';
            else if(count_>3&&count_<=9)
                res+='9';
            else res+="27";
        }
    cout<<res;
    system("pause");
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/littlepage/p/11966803.html