UVA540 Team Queue——题解 by hyl天梦

UVA540 Team Queue 题解

题目描述:题目原题 https://vjudge.net/problem/UVA-540

Queues and Priority Queues are data structures which are known to most computer scientists. The
Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the
queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches
the queue from head to tail to check if some of its teammates (elements of the same team) are already
in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail
and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are
processed from head to tail in the order they appear in the team queue.
Your task is to write a program that simulates such a team queue.
Input
The input file will contain one or more test cases. Each test case begins with the number of teams
t (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elements
belonging to the team and the elements themselves. Elements are integers in the range 0..999999. A
team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:
• ENQUEUE x — enter element x into the team queue
• DEQUEUE — process the first element and remove it from the queue
• STOP — end of test case
The input will be terminated by a value of 0 for t.
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation
of the team queue should be efficient: both enqueing and dequeuing of an element should
only take constant time.
Output
For each test case, first print a line saying ‘Scenario #k’, where k is the number of the test case. Then,
for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank line
after each test case, even after the last one.
Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0
Sample Output
Scenario #1
101
102
103
201
202
203
Scenario #2
259001
259002
259003
259004
259005
260001

题目翻译:(来自洛谷)

题意翻译

有t个团队的人正在排一个长队。每次新来一个人时,如果他有队友在排队,那么新人会插队到最后一个队友的身后。如果没有任何一个队友排队,则他会被排到长队的队尾。 输入每个团队中所有队员的编号,要求支持如下3中指令: ENQUEUE x:编号为x的人进入长队 DEQUEUE:长队的队首出队 STOP:停止模拟 对于每个DEQUEUE指令,输出出队的人的编号。


思路:

用STL完成此题。map 表示某人某组,队列q1与q2【n】,考虑到同伙人永远在一起,故用q1来存队,用q2【n】来存每一队里人;

定义如下:

using namespace std;
const int MAXN=1010;
typedef map<int,int> Map;
typedef queue<int> Queue;
Map a;

由于此题有多组数据,我们采用以下方法输入:

void intt(int n)
{
    for(int i=1;i<=n;i++)
    {
        int q;
        cin>>q;
        for(int j=1;j<=q;j++)
        {
            int x;
            cin>>x;
            a[x]=i;//表示x是i队的
        }
    }
}

其中 n表示这组数据有几队人,a是map型的。

让我们看一下主程序:

int main()
{
    int n;
    int j=0;
    while(cin>>n)
    {
        Queue q1,q2[MAXN];
        if(n==0) break;
        intt(n);
        j++;
        cout<<"Scenario #"<<j<<endl;
        string s1;
        int who;

这只是一部分,在其中定义队列,如果n为0,跳出。j表示这是第几组数据,为了输出格式。定义了一个字符串s1,和将要入队的人。

核心代码:

        while(cin>>s1)
        {
            if(s1=="STOP") break;
            if(s1=="ENQUEUE")
            {
                cin>>who;
                if(q2[a[who]].empty()==1) q1.push(a[who]);
                q2[a[who]].push(who);
            }
            if(s1=="DEQUEUE")
            {
                int top=q1.front();
                cout<</*top<<" "<<*/q2[top].front()<<endl;
                q2[top].pop();
                if(q2[top].empty()==1)
                {
                    q1.pop();
                }
            }
        }

当s1为stop,说明操作结束。

若是"ENQUEUE" 执行入队操作,假如入队人所在队是第一次入队,则在q1里把这个队名称加入。在q2这个队中加入入队人。

若执行"DEQUEUE"出队操作,则看首位队的名称,存入top,再出队首位队的第一个人,如果出队后这个队为空,则把这个队的名称出队。

cout<<endl;

最后回车,题目要求。

整体代码如下:

#include<iostream>
#include<queue>
#include<map>
#include<string>
#include<cstdio>
using namespace std;
const int MAXN=1010;
typedef map<int,int> Map;
typedef queue<int> Queue;
Map a;
void intt(int n)
{
    for(int i=1;i<=n;i++)
    {
        int q;
        cin>>q;
        for(int j=1;j<=q;j++)
        {
            int x;
            cin>>x;
            a[x]=i;
        }
    }
}
int main()
{
    int n;
    int j=0;
    while(cin>>n)
    {
        Queue q1,q2[MAXN];
        if(n==0) break;
        intt(n);
        j++;
        cout<<"Scenario #"<<j<<endl;
        string s1;
        int who;
        while(cin>>s1)
        {
            if(s1=="STOP") break;
            if(s1=="ENQUEUE")
            {
                cin>>who;
                if(q2[a[who]].empty()==1) q1.push(a[who]);
                q2[a[who]].push(who);
            }
            if(s1=="DEQUEUE")
            {
                int top=q1.front();
                cout<</*top<<" "<<*/q2[top].front()<<endl;
                q2[top].pop();
                if(q2[top].empty()==1)
                {
                    q1.pop();
                }
            }
        }
        cout<<endl;
    }
    return 0;
}

请勿抄题解,谢谢,传载请注明作者。

猜你喜欢

转载自www.cnblogs.com/TianMeng-hyl/p/11965309.html