【二分查找】 Can you solve this equation? HDU基础04二分法02

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

Author

Redow



#include <bits/stdc++.h>
using namespace std;

double f(double x)
{
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
	int T;scanf("%d",&T);
	while(T--)
	{
		long long y;
		scanf("%lld",&y);

		double l=0,r=100;
		double ans=-1;

		for(int i=0;i<100;i++)
		{   //循环一定次数保证精度
			double mid=(l+r)/2;
			if(abs(f(mid)-y)<=1e-6)
			{
				ans=mid;
				break;
			}
			else if(f(mid)>y)
				r=mid;
			else l=mid;
		}

		if(ans==-1)
			printf("No solution!\n");
		else
			printf("%.4f\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80281248